Ads_700x200

tme

wtorek, 28 lipca 2015

ECLIPSE - START plus pierwszy program

Witam,

W związku z tym, że na przestrzeni czasu wydałem już wiele poradników odnośnie startu z Eclipse, omawiając różne jego wersje, sposoby pobierania, gdzie widzowie (szczególnie całkowicie początkujący) musieli zmagać się z wyszukiwaniem stron na których mogliby pobrać nie tylko odpowiednią wersję Eclipse, ale także toolchain do języka C czy też właściwą wersję AVR plugina, to postanowiłem to wszystko ujednolicić w postaci tego poradnika. Tym bardziej, że w każdym z poprzednich często zapomniałem wspomnieć o jakimś drobiazgu, wspominałem o nim w innym ale tam zapominałem o jeszcze innym drobiazgu - no i tym sposobem po latach zrobił się troszkę twz MISZ-MASZ w tych moich poradnikach. Do dzisiaj początkujący (nie wiem dlaczego) ale jakimś dziwnym trafem - wyszukują akurat te najbardziej archaiczne z moich poradników o Eclipse zamiast NAJNOWSZEGO no i zaczyna się bonanza ;) .... Do tego maile, że wciąż komuś coś nie działa. 
Słuchajcie - rozprawiamy się dzisiaj z tym RAZ na ZAWSZE, mam nadzieję, że mi się uda. Zapraszam więc na poradnik - który pokaże wam jak wystartować z ECLIPSE i to nie ważne w jakiej wersji - chociaż ja przygotuję tutaj dla was WSZYSTKO ! Co to znaczy? Ano będziecie mogli pobrać z JEDNEGO miejsca - tu z tego bloga, z tego artykułu (na dole strony) z podanych linków po kolei, zarówno zawsze najnowszego polecanego przeze mnie ECLIPSA, najnowszego toolchaina do C, najnowszego sprawdzonego i poprawionego AVR Plugin'a itp. Myślę - że od teraz nie będzie problemów ;) ... dlatego dzisiaj - a mamy 2015 rok - lipiec dokładnie 26-go lipca, zapraszam was na MARSA ;) tak tak ... na dzisiaj to najnowszy i sprawdzony przeze mnie - także polecany Eclips ;) Pamiętajcie jednak, że w przyszłości może to być jeszcze nowsza wersja np PLUTON ;) ... ale zasady instalacji pozostaną praktycznie takie same.

zatem jedziemy !



Poniżej filmy:








;)


Uwaga! ponieważ użytkownicy przestarzałych już windowsów XP, nie mogą pobrać JAVA zgodnie z instrukcją z poradnika - to dlatego w tabelce poniżej umieściłem link do wersji Java 7.1 którą można jeszcze uruchomić na starym windowsie XP. (Nie uruchamiać tego na nowszych wersjach windowsa!)


.


-------------------------------------------------------------------------------


Jeśli masz kłopoty z instalacją sterowników do FT232R to przede wszystkim na początek, należy je poprawnie odinstalować za pomocą oprogramowania producenta. Poniżej krótki tutorial krok po kroku skąd pobrać program, jak go uruchomić i jakie czynności wykonać.






8 - kliknij przycisk ADD
9 - zaznacz myszką VID oraz PID
10 - kliknij przycisk Remove Devices i poczekaj



Po całym procesie deinstalacji - powtórz ponownie instalację sterowników do FT232 tak jak omawiałem i pokazywałem to w poradniku.




98 komentarzy:

  1. Panie Mirku, niestety nie widać wideo. Na Pana kanale na YT również go nie widzę.

    OdpowiedzUsuń
    Odpowiedzi
    1. Spokojnie, czekamy - to bardzo skomplikowany z punktu widzenia montażu poradnik, naprawdę wymaga to wiele pracy ode mnie i przede wszystkim przygotowania już tego artukułu z linkami do pobrania - gdyż czas się zapętli ;) będę wprawdzie dopiero tworzył ten poradnik a jednocześnie w jego trakcie będę pokazywał jak pobrać pliki ;) ..... i w ten sposób musiałem wybrnąć - jak widać ... Dopiero za jakiś czas wszystko zostanie uzupełnione i pokaże się na YT ... proszę o cierpliwość

      Usuń
  2. Witam,
    jeśli chodzi o AVR plugin for Eclipse to dostępna jest wersja 2.4.2 ( http://sourceforge.net/projects/avr-eclipse/files/avr-eclipse%20stable%20release/2.4.2/ )
    Mogę prosić o informację dlaczego tu używamy wersji 2.4.1 (sprawdzonej i poprawionej), jak napisano wyżej w tekście? Czy ta wersja 2.4.1 zawiera jakieś krytyczne lub usprawniające poprawki?

    Pozdrawiam

    OdpowiedzUsuń
    Odpowiedzi
    1. Wersja 2.4.2 jest po prostu jeszcze nie przerobiona tak żeby automatycznie wykrywała atmel toolchain .... i trzeba zdaje się ręcznie ustawiać ścieżki. I tylko na razie z tego prostego powodu daję 2.4.1 bo ta działa poprawnie w tym zakresie ... Chyba że coś się zmieniło - szczerze - to już kilka tygodni nie zaglądałem do 2.4.2.

      Usuń
  3. Witam,

    w 7:00 minucie na tablicy mamy www.java.com a nasz naukowiec z kosmosu mówi www.java.org, a pod tym adresem nic nie ma.

    A tak poza tym to jak zwykle świetny poradnik za który bardzo dziękuję. Oczywiście czekam z niecierpliwością na kolejne części :D

    OdpowiedzUsuń
  4. Tak racja, naukowiec z kosmosu, ten prelegent się pomylił, dostał już opieprz, naganę i o mało co go z roboty nie wywalili, więc miejmy nadzieję, że kolejnym razem się nie pomyli ;) .... dobrze, że chociaż na tablicy dobrze napisał ;)

    OdpowiedzUsuń
  5. Witam,
    Zainstalowałem avrdude przez mkavrcalulator, gdy wywoluje avrdude.exe w konsoli, i wpisuję komendę "avrdude -c usbasp -p m8" otrzymuję komunikat "Ta aplikacja nie będzie działać na Twoim komputerze, aby znaleźć wersję dla tego komputera skontaktuj się z wydawcą" a w wierszu poleceń "odmowa dostępu" mam windows 8.1 64 bitowy, czy dla tego windowsa avrdude musze pobierać z innego źródła?

    OdpowiedzUsuń
    Odpowiedzi
    1. Dlatego że pewnie kliknąłeś sobie przycik (ptaszka) "Install Eclipse Progress" ... a nie doczytałeś do czego to jest. Pokazuje to fajny pasek postępu w Eclipse podczas programowania ... ale też podkłada się zamiast AVRDUDE. Więc jeśli chcesz "z ręki" odpalać avrdude - to uruchamiaj

      avrdude_mk.exe

      a nie avrdude.exe - ... zajrzyj sobie do folderu avrdude ;) ..... ten avrdude_mk teraz używasz jako avrdude

      teraz jaśniej ? ;)

      Usuń
    2. Hm... w sumie nie zaznaczyłem tej opcji, ale objaśnienie na pewno przydatne.
      Zauważyłem, że również AVRdude któremu miałem w pakiecie z winavr również taki błąd zwraca (brak dostepu) :/

      Usuń
    3. No to sprawdź sobie antywirusa albo inne jakieś takieś - masz problem nie z eclipsem i nie z avrdudem tylko z własnym systemem

      Usuń
  6. bardzo fajny poradnik.mam jedno pytanie czy te drajwery do ATB-FT232R są darmowe?

    OdpowiedzUsuń
    Odpowiedzi
    1. No przecież pokazywałem skąd je pobrać w poradniku, czy widać było żebym coś tam musiał płacić ? ;) skądże znowu taki pomysł ?

      Usuń
  7. Witam.
    Miałem zainstalowany Według poradnika Pana Mirka ECLIPS Indigo, i służył. A po przeinstalowaniu na Lunę nie miałem już pożytku, - nie opanowałem.
    Teraz jest MARS, jest OK, jednak nie widzę wygenerowanych plików *.hex.
    Jak je wygenerować i jak je zobaczyć?
    Oczywiście BEBUG/RELEASE ustawione są prawidłowo.

    OdpowiedzUsuń
    Odpowiedzi
    1. Najpierw to wejdź na nasze forum: www.forum.atnel.pl

      i tam porządnie opisz swój problem, czyli np pokaż zrzut ekranu jaki masz komunikat błędu jeśli jest, co pokazuje się w okienku CONSOLE, jak tworzysz projekt itp itd - wtedy będzie ci można pomóc, bo po prostu coś zrobiłeś niezgodnie z tym poradnikiem - nie ma mocnych

      inny sposób to obejrzyj jeszcze raz dokładnie poradnik ... zobacz chociażby ten wątek na forum:

      http://forum.atnel.pl/topic12762.html?sid=76aed674f48950ba2b0fe341b01d6f36

      a na końcu radość

      http://forum.atnel.pl/post138832.html#p138832

      Usuń
  8. witam zrobiłem wszystko po kolei jednak eclipse nie chce zainstalować oprogramowania przepraszam ale co mam robić?

    OdpowiedzUsuń
    Odpowiedzi
    1. Co masz zrobić ? .... Masz zrobić DOKŁADNIE po kolei to co ja w poradniku, bo robisz po swojemu - nie wychodzi ci i masz .... Nie wiem ile można prosić kogoś aby zrobił DOKŁADNIE tak jak w poradniku jak coś nie wychodzi

      Usuń
  9. Dziś, nie wiem dlaczego wysiadł mi Eclipse Mars. Zgubił mi workspace, kompilacje wychodziły z jakimiś śmiesznymi błędami. Chcąc ściągnąć jego ponownie, zauważyłem że jest nowy instalator Eclipse Mars. Oczywiście instalacja przeszła bez problemu, więc powiadamiam wszystkich o nowości.

    OdpowiedzUsuń
  10. Chciałem tylko zdementować informację że Java 8 nie chodzi na WINXP, instalacja jej jest nie zalecana przez Oracle'a na staruszku XP, ale daje się zainstalować i hula wyśmienicie wraz z Eclips Mars.

    OdpowiedzUsuń
  11. Bardzo dobry poradnik, wszystko działa jak należy.

    OdpowiedzUsuń
  12. Eclipse działa. Blink_led też działa, ale inny projekt, który uruchamiałem pod AtmelStudio 6.2 oraz 7.0 już na eclipse nie zadziałał. Mam aż 7 błędów.
    Jednak jestem za słaby aby to rozwiązać.
    Jurek

    OdpowiedzUsuń
    Odpowiedzi
    1. A po co się męczysz z tym Atmel Studio ?

      Poza tym jeśli chcesz już koniecznie to zadawaj pytania ale z pokazaniem kodu na naszym przyjaznym forum:

      www.forum.atnel.pl

      wtedy będzie można ci coś pomóc ... bo tu jak ?

      Usuń
  13. Zrobilem wszystko jak nalezy ale nie miga mi dioda. Ogladalem te filmy po 2 razy i jeszcze raz wszystko sprawdzilem ale nic sie nie dzieje. Mam Windows 8 64 bit

    OdpowiedzUsuń
    Odpowiedzi
    1. No bo albo nie zrobiłeś czegoś tak jak w poradniku albo źle diodę podłączyłeś ... sorki ale nie ma innego wyjścia.... A windows nie ma tu nic do rzeczy

      Usuń
  14. Witaj Mirku!
    Konfiguruję eclipse od nowa i szukam poradnika w którym był screenshot ze ścieżkami w eclipse do winavr. ostatecznie trafiłem tutaj i zonk, nadal nie ma tego. Wstaw proszę taki screenshot, ułatwi to następnym poszukiwania. Ja tym czasem zabiram się za poszukiwanie tego w filmach.

    Pozdrawiam

    OdpowiedzUsuń
    Odpowiedzi
    1. Powiedz mi panie kolego, masz poradnik tutaj od A do (kurczę Z) ... a ty zamiast zrobić DOKŁADNIE to co w poradniku to wymyślasz sobie jakieś ścieżki... Powiedz mi po jakiego grzybka ? Przecież za chwilę - zgłosisz się z kolejnym pytaniem, że np wszystko się udało, że niby WSZYSTKO zrobiłeś to co w poradniku - tylko ci Eclipse nie widzi listy procesorów .... Po co sobie tak życie komplikować ....

      Zapomnij o tym screnshocie, zrób to co w TYM PORADNIKU i nie będziesz musiał żadnych ścieżek ustawać ... i zapomnij i wykasuj stary SZROT WinAVR o czym też mówię w tym poradniku.

      Usuń
  15. Witam Pana.
    Mam pewien problem. Zrobiłem wszystko tak jak w poradniku na Atmedze16A i wyszło wspaniale i przeszedłem na ATtiny 2313A i nie wychodzi. Co robie źle?

    Pozdrawiam

    OdpowiedzUsuń
    Odpowiedzi
    1. Panie to jakiś żart? .... Zapytaj czarodzieja ... tak powinienem ci odpowiedzieć. A jak chcesz lepszej podpowiedzi to może opisz DOKŁADNIE ... co ci tam nie wychodzi ?

      Sam przeczytaj jeszcze raz to co napisałeś i powiedz mi czy nie złapiesz się za głowę? .... co to za pytanie????

      "Nie wychodzi mi, co robię źle?" ..... masakra

      Usuń
    2. Dioda wlacza sie i wylacza mniej wiecej co 1,5 sekundy. Gdy ustawie oscylatory na 8mhz w avrcalculator i eclipse mam to samo. Musze zawsze wpisac to opoznienie "-B 327". Bo gdy je skasuje nie chce mi wgrac programu do procesora.

      Usuń
    3. Bo nie ustawiłeś procka Fusebitami na 8MHz, wejdź sobie w zakładkę "FUSY UPROSZCZONE" i jak wykryjesz procka ATtiny to PRZECZYTAJ sobie co w tej zakładce masz napisane na CZERWONO ....

      Bo ja ci mówię że nadal masz taktowanie 1MHz

      Usuń
  16. Dobrze zobacze jeszcze raz i dam znac czy sie udalo. A moze byc taka mozliwosc ze procek jest uszkodzony? Bo w razie czego mam druga kosc.

    OdpowiedzUsuń
    Odpowiedzi
    1. Kurczę jak ci procek działa i daje się odczytywać w MkAvrCalculator to wyjaśnij mi skąd masz TAKIE KOSMICZNE pomysły o uszkodzonym procku?

      Usuń
  17. Teraz nie mam dostepu do kompa wiec dopiero wieczorem zobacze.

    OdpowiedzUsuń
  18. Nie wiem tak jakos mi przyszlo do glowy co prawda jeszcze go za bardzo nie "uzywalem" bo uczylem sie z innej troche ksiazki na Atmedze i stanalem zaraz na poczatku bo cos mi nie wychodzilo i pozniej znalazlem ten blog przepadkiem:p

    OdpowiedzUsuń
    Odpowiedzi
    1. To zaglądaj jeszcze na nasze forum: www.forum.atnel.pl i zapamiętaj na zawsze szczególnie gdy jesteś początkujący - jak coś nie działa, to nie wymyślaj, że to procesor jest zły, że kompilator, że eclipse czy coś ;) tylko szukaj z uporem błędu który popełniasz. W ten sposób szybciej będziesz się uczył - zobaczysz ;)

      Usuń
    2. Dobrze juz doszedlem co i jak :). Okazalo sie ze mam ustawione jeszcze wewnetrzne dzielenie czestotliwosci przez 8 na mkavr calculatorze. Pan sie tam bawil i na poczatku nawet nie zauwazylem roznicy dopiero jak obejrzalem kilka razy ostatnia czesc poradnika :)

      Usuń
    3. No widzisz ;) ... to teraz zapamiętasz już na zawsze o co w tym chodzi i sam stwierdzisz jakie to teraz proste ;)

      Usuń
    4. teraz podpiąłem Atmege i nie mam tej opcji w mkavrze :P

      Usuń
    5. No to jak ty myślisz ? to zależy od MkAvrCalculatora czy od procka ? ... eeeeh panie panie - nota PDF w łapki i tam wszystko znajdziesz ;) ... Starsze procki zwykle tego nie mają a nowsze mają - co w tym dziwnego ?

      Usuń
    6. ja przedtem w fusach nigdy nie grzebalem wiec nie mialem pojecia :)

      Usuń
    7. Kiedyś musi być "ten pierwszy raz". Tak się zdobywa doświadczenie.

      Usuń
    8. a teraz z innej beczki trochę. Te sterowniki pod usb-asp na windowsie xp sp3 powinny bez problemu się zainstalować? U mnie miał jakieś opory ale ostatecznie przeszło tak jak Pan opisuje:)

      Usuń
    9. Tak działają na XP również, a to że się dłużej instalują ... no cóż... dziadek XP to jednak dziadek

      Usuń
    10. no fakt co prawda to prawda :P
      dobrze, bardzo dziękuję za pomoc i informacje
      dobranoc :)

      Usuń
  19. Zainstalowałem "eklipsika" (he he) - niewiarygodnie żmudne przedsięwzięcie i mam nadzieję że cokolwiek pozytywnego z tego wynika bo użycie/instalacja WinAVR-a to przy tym jak kliknięcie myszą więc okazji do błędów o wiele mniej.
    O dziwo wszystko do kupy (choć w moim odczuciu strasznie połatane) działa.
    Mam obawę o setkę okazji do możliwych błędów.

    OdpowiedzUsuń
    Odpowiedzi
    1. To nie bądź taki strachliwy i pełen obaw tylko działaj. Ale jeśli zostawiłeś i nie skasowałeś starego szrota WinAVR'a to nie dziwię się jeśli już wkrótce zaczną ci się pojawiać problemy. Bo w tym poradniku WYRAŹNIE mówię aby zainstalować Atmel Toolchain zamiast szrota WinAVR

      Usuń
  20. Panie Mirku zrobiłem dokładnie tak jak w poradniku ale mam problem z migającą diodą tzn po kompilacji wyskakuje mi error: LED.map: No such file or directory. Dlaczego nie mam tego LED.map?

    OdpowiedzUsuń
  21. Zainstalowałem wszystko dokładnie tak jak w poradniku (robiłem to 2 razy). Kompilacja pierwszego programu kończy się błędem error: LED.map: No such file or directory. Jestem mocno początkujący. Dlaczego mi brakuje tego LED.map?

    OdpowiedzUsuń
    Odpowiedzi
    1. Panie kolego odpowiedź jest TYLKO JEDNA :( - nie zrobiłeś wszystkiego niestety tak jak w poradniku i to jest pewne jak amen w pacierzu. Po pierwsze weź pod uwagę, że już setki jak nie tysiące użytkowników korzystają z tych poradników i każdemu działa ... a jak się rzadko tak jak u ciebie już zdarzy, że komuś nie działa - to też ZAWSZE się okazuje, że nie zrobił czegoś z poradnika .... I NIE MA INNEGO WYJŚCIA panie kochany ....

      Ja to pokazałem już tak na maxa od A do Z - że prościej się nie da ....

      albo nie zainstalowałeś atmel toolchaina, albo nie inicjujesz projektu jako AVR GCC zgodnie z poradnikiem zresztą - albo w ogóle na kompie zainstalowałeś sobie inny kompilator C i teraz ci się gryzą

      Usuń
    2. Prosta podpowiedź dla ciebie - jak nie umiesz sobie poradzić z naprawą swojego windowsa albo nie panujesz nad tym jakie tam inne kompilatory poinstalowałeś albo może nie skasowałeś starego szrota WinAVR to weź sobie wygeneruj windows od nowa i zrób jeszcze raz dokładnie to co w poradniku i zobaczysz że zadziała ;)

      Usuń
  22. Witam Pana.
    Chciałem dowiedzieć się pewnej rzeczy. Korzystam z płytki xplained mini 168PB, która ma wbudowany moduł mEDBG pozwalający na programowanie i debugowanie przez kabel USB w środowisku Atme Studio... No właśnie Atmel studio :( zdecydowanie nie przypadliśmy sobie do gustu. Po obejrzaniu Pana filmików chciałbym przerzucić się na Eclipse'a, jednak zastanawia mnie czy z poziomu Eclipse'a można programowac przez kabel USB i moduł mEDBG ( tak samo jak w ATmel studio) czy też konieczne jest kupienie/zrobienie "zewnętrznego" programatora ?

    OdpowiedzUsuń
    Odpowiedzi
    1. Przykro mi nie znam tej płytki ani pewnie jeszcze wielu innych - więc nie umiem pomóc.

      Usuń
  23. Witam Pana,

    Zainstalowałem wszystko zgodnie z poradnikiem, jednak przy próbie zbudowania projektu dostaję błąd "avr-gcc.exe - Błąd aplikacji. Aplikacja nie została właściwie uruchomiona (0xc0000142)." Czy ma Pan pomysł co mogłem zrobić źle?

    OdpowiedzUsuń
  24. Odinstalowałem wszystko, łącznie z Eclipse i zainstalowałem ponownie, jednak dalej mam ten sam problem. Czy oprócz odinstalowania starych programów (WinAVR oraz Atmel Studio) powinienem coś jeszcze zrobić?

    OdpowiedzUsuń
    Odpowiedzi
    1. No to masz pewnie jakiegoś antywira dziwnego co zżera ci pliki toolchaina - to też się zdarza

      albo masz jeszcze inny kompilator języka C albo C++ zainstalowany na kompie i źle ścieżki poustawiane w windows

      Usuń
  25. Mam tylko systemowego antywirusa, ale mam zainstalowane Visual Studio. Powinienem go odinstalować, czy jest możliwość poustawiania ścieżek poprawnie?

    OdpowiedzUsuń
    Odpowiedzi
    1. Widzisz - jak już ktoś używa kilka kompilatorów C/C++ to mi się troszkę nie do końca chce wierzyć, że taka osoba nie wie jak się ustawia ścieżki (PATH) w zmiennych środowiskowych windows. Chyba że ktoś dla zabawy sobie instaluje różne kompilatory - wtedy rzeczywiście najczęściej ma takie problemy. To jak się ustawia ścieżki w zmiennej środowiskowej windows i tłumaczenie co to jest - no przykro mi musisz zrozumieć, że to już jakby troszkę inna całkiem bajka i hmmm jakby kwestia znajomości - windowsa. Prościej pewnie będzie ci odinstalować Visual Studio być może ... ale ja już widziałem osoby, które jeszcze miały poinstalowane np GCC dla ARM'ów, i inne .... bo tak ktoś chciał wszystkiego popróbować w później miał zdziwienie że działa mu tylko jeden albo dwa ze wszystkich kompilatorów ...

      Proponuję ci zrobić sobie prosty test: Odpal nowego windowsa nawet na maszynie wirtualnej i zobaczysz że jak zainstalujesz to co mówię w poradniku to zadziała .... wtedy będziesz wiedział - że musisz sobie w windowsie porządek zrobić - ok?

      Usuń
    2. Przeinstalowałem windowsa i działa jak trzeba, dziękuję za pomoc :)

      Usuń
  26. Aż boli oglądanie, jak się pan Mirek produkuje, żeby przekonać użytkowników co mają robić. Może jednak ludzie, którzy chcą programować mikrokontrolery, powinni coś wiedzieć o systemie operacyjnym, którego używają i o prograwowaniu w ogólności?
    Nie twierdzę, że metoda pana Mirka jest jedyna i najwłaściwsza (on zapewne też tak nie twierdzi), ale do diabła, "wyskakuje mi error #152345278 - co robić????" Odetchnąć spokojnie, policzyć do dziesięciu, cofnąć się do ostatniego miejsca w którym wiedzieliśmy "o co biega" i jechać dalej.
    Pozdrowienia, panie Mirku.

    OdpowiedzUsuń
  27. Witam Pana,
    postępowałem do końca zgodnie z pańskim poradnikiem, jednak przy próbie wgrania programu do Atmegi 8 w środowisku Eclipse wyskakuje błąd "rc=-1". Przy sprawdzeniu poprawności połączenia za pomocą mkAVR Calculator wszystko przebiega pomyślnie. Czy ma Pan pomysł, gdzie popełniłem błąd?

    OdpowiedzUsuń
    Odpowiedzi
    1. Ja nie mam pomysłu gdzie popełniasz błąd tylko w 100% wiem gdzie go popełniasz i nie jesteś pierwszy i ostatni. Co rusz ktoś pisze, że zrobił wszystko zgodnie z poradnikiem i ma taki błąd ....

      A ja wtedy zawsze mówię, że nie zrobiłeś wszystkiego zgodnie z poradnikiem bo jeśli MkAvrCalculator wykrywa a w Eclipse ci nie działa to znaczy - że nie obejrzałeś poradnika dokładnie bo PORUSZAM W PORADNIKU TEN PROBLEM - toż on mi (tzn przez tych wszystkich co nieuważnie oglądali i moje wcześniejsze poradniki) i nie chciało im się nigdy też nigdy zajrzeć na bloga do artykułu w którym już ODDZIELNIE TYLKO O TYM PROBLEMIE mówię

      http://mirekk36.blogspot.com/2013/06/gdy-nie-dziaa-usbasp-pod-eclipsem.html

      to niestety jak grochem o ścianę .....

      A więc panie kochany w tył zwrot i obejrzyj jeszcze raz dokładnie albo obejrzyj ten poradnik z linku wyżej

      Usuń
  28. Witam, nie wiem dlaczego ale nie możliwe jest już pobranie sterowników z tej strony http://www.ftdichip.com/Drivers/D2XX.htm opcja "setup exexutable" brak :(

    OdpowiedzUsuń
    Odpowiedzi
    1. Kurka wodna! rzeczywiście - szlag! ... aż sam się zdenerwowałem.

      No cóż, będę musiał na nowo próbować rozpoznać temat czy przypadkiem nie trzeba używać teraz D3XX ... ale to dam znać oficjalnie jak coś ....

      Usuń
    2. ok fakt na D3xx jest taka opcja dziękuję za odp już myślałem że u mnie coś nie tak :)

      Usuń
    3. Jeszcze dodam tak może komuś to pomoże ten najnowszy plik wgrywa się ale niestety nie działa (nie wykrywa urządzenia). Na ATB-USB wszystko działa na drugi musimy poczekać :)

      Usuń
  29. Udało się już coś zaradzić na ten problem ?

    OdpowiedzUsuń
    Odpowiedzi
    1. Na jaki problem ? Sterowników do FT232R ? ... przecież są nadal na stronie do pobrania tyle, że nie w postaci EXE, a więc nadal można śmiało również te co są D2XX instalować i wszystko śmiga.

      Usuń
  30. How to setup eclipse for 32-bit mcu ? like uc3a0512 for example.
    Can you give me some advice ?

    OdpowiedzUsuń
  31. Moje pytanie wciąż czeka i prosiłbym o jego dodanie przez moderatora tej strony

    OdpowiedzUsuń
    Odpowiedzi
    1. Building target: DIODA TEST LED.elf'
      'Invoking: AVR C Linker'
      avr-gcc -Wl,-Map,DIODA TEST LED.map -mmcu=atmega8 -o "DIODA TEST LED.elf" ./main.o
      avr-gcc: error: TEST: No such file or directory
      avr-gcc: error: LED.map: No such file or directory
      make: *** [DIODA TEST LED.elf] Błąd 1

      mam taki problem i nie badzo wiem o co chodzi dodam ze zmieniałem tak jak w poradniku ścieżkę gcc

      Usuń
  32. właściwie chodzi mi o ten błąd ponieważ nie bardzo wiem o co chodzi a avrdud wgrywałem z mkAVRcalculator i postępowałem zgodnie z filmikiem w sensie zmieniłem potem ścieżkę docelową gcc i nie bardzo wiem o chodzi
    avr-gcc -Wl,-Map,DIODA TEST LED.map -mmcu=atmega8 -o "DIODA TEST LED.elf" ./main.o
    avr-gcc: error: TEST: No such file or directory
    avr-gcc: error: LED.map: No such file or directory
    make: *** [DIODA TEST LED.elf] Błąd 1

    dlatego prosiłbym o pomoc

    OdpowiedzUsuń
  33. czeka na zatwierdzenie przez moderatoro poniewaz nie moge dodać bezposrednio ;/

    OdpowiedzUsuń
    Odpowiedzi
    1. eeee panie typowy objaw nie obejrzenia uważnie poradnika .... żaden nietypowy problem. Nie zapisałeś projektu i to tyle

      Usuń
  34. Witam niestety nie mogę poprawnie zainstalować paczki z plugin ;/ wyskakuje mi błąd w połowie instalacji i później nic nie mogę zrobić w programie bo nie ma potrzebnych składników do dalszej pracy ;/ jakas rada ?

    OdpowiedzUsuń
    Odpowiedzi
    1. Ale ja dokładnie wszystko omówiłem w poradniku, jeśli masz problem to masz problem z windowsem. Wygeneruj sobie windows od nowa i zobaczysz że wszystko pójdzie dobrze - jeśli masz kłopoty z doprowadzeniem windowsa do normalnego działania.

      Usuń
    2. Jakby ktoś miał taki sam problemu to u mnie podziałało instalacja na innym dysku :)

      Usuń
  35. AVR_plugin_241 gdzie go wsadzić bo poradnik jak dla mnie jest stosunkowo za chaotyczny. Panie Mirku proszę się nie gniewać ale step by step 1.ściągnij a,b,c 2.rozpakuj b,c 3.skopiuj b do .. 4 zainstaluj c 5.odpal eclipsa 6.ustaw to i to 7. zacznij pisać program. Bez skakania od A do P po drodze trącając X.

    OdpowiedzUsuń
    Odpowiedzi
    1. Jeśli jest dla ciebie jednego na tysiąc zbyt chaotyczny to prosta sprawa - nie oglądaj go i znajdź lepszy dla siebie poradnik. Bo co ja ci innego poradzę ... .... albo ... albo nakręć sam lepszy i mniej chaotyczny.

      Usuń
  36. Witam,
    jestem zatwardziałym BASCOM'mowcem chciałbym w końcu ruszyć z C. Czy jest jakaś możliwość instalacji srodowiska Eclipse z zachowanym oprogramowaniem (WinAVR + BascomAVR)?

    OdpowiedzUsuń
    Odpowiedzi
    1. Przecież nie pracując na Eclipse wcale nie trzeba kasować bascoma ;)

      Usuń
  37. Panie Mirku ma pan może jakąś pomocną rade do postów z 27 lutego ???

    OdpowiedzUsuń
    Odpowiedzi
    1. Znalazłem rozwiązanie :D

      Usuń
  38. Eclipse Mars.2 dostępny od 26 lutego. Testował już ktoś? Szczególnie z nowym toolchainem 3.5.1?

    OdpowiedzUsuń
  39. Witam serdecznie.

    Mój problem wygląda tak że niby wszystko śmiga kompiluje się ale wyskakuje błąd 0xc0000142 a w konsoli mam komunikat o błędach :
    vr-gcc -Wall -Os -fpack-struct -fshort-enums -ffunction-sections -fdata-sections -std=gnu99 -funsigned-char -funsigned-bitfields -mmcu=atmega328p -DF_CPU=8000000UL -MMD -MP -MF"main.d" -MT"main.o" -c -o "main.o" "../main.c"
    make: *** [main.o] Błąd -1073741502

    niby nie wywala żadnego błędu w kodzie i wszystko zakańcza ale spodziewam się że nie można tego zwyczajnie olać i jak dalej wsiąknę we wgrywanie do procesora to będzie to mnożyć kłopoty. Wszystkie rzeczy mam pobrane wg poradnika zainstalowane wg instrukcji. jedynie co odbiega od normy to Windows 10 i zastanawiam się czy tu nie leży problem.

    Pozdrawiam

    OdpowiedzUsuń
    Odpowiedzi
    1. Masz kociego antywirusa, który ci blokuje toolchaina albo nie zainstalowałeś najnowszego toolchaina

      Usuń
    2. Mam identyczny problem, co kolega Jacek. Zainstalowałem i zaktualizowałem toolchain na najnowszy - problem nie zniknął.
      Co to znaczy "koci antywirus"?

      Usuń
    3. wyłącz na czas testów kociego wirusa to sam się ew przekonasz co i jak

      Usuń
  40. Jestem pod wrażeniem. Mam kilka prostych programików już na koncie, ale z wielką przyjemnością skorzystam z porad dotyczących Eclipse, który właśnie zainstalowałem z poradnikiem w tle. Wszystko pięknie działa. Bardzo dziękuję. Pozdrawiam.

    OdpowiedzUsuń
  41. Jak rozumiem teraz już nie używa się WinAVR, tylko toolchaina?

    OdpowiedzUsuń
    Odpowiedzi
    1. Dobrze kolega rozumie, i to już od kilku ładnych lat nie używa się dziadka WinAVR'a ;)

      Usuń
  42. Jestem świeżutko po obejrzeniu poradnika instalacji nowej wersji Eclipse'a i wszystko przebiegło elegancko z jednym małym zgrzytem.
    Przy próbie uruchomienia Eclipse Mars ujrzałem komunikat, że nie można było utworzyć maszyny wirtualnej Java. Java oczywiście wg. poradnika (specjalnie odinstalowałem tę obecną już w systemie). Jednocześnie stary Eclipse Indigo na tej jawie odpalił się bez problemu.

    Rozwiązanie szybko znalazłem w Internecie. Należało w pliku eclipse.ini zmienić wartość w ostatniej linijce na "-Xmx512m". Oryginalnie ten parametr wyglądał tak "-Xmx1024m". Bardzo możliwe, że mój stary komputer z zainstalowanym Windows XP i 2GB RAM-u nie był w stanie w jakiś sposób podołać wymaganiom Eclipse.
    W każdym razie po tej poprawce wszystko zadziałało bez problemu.

    Mam jeszcze pytanie do Mirka: czy ewentualne upgrade'y toolchaina zawsze odbywają się w taki sposób, że nadpisuje się pliki istniejącej instalacji czy w razie wyjścia nowej wersji można po prostu odinstalować starą i wgrać nową?

    Dzięki za świetny poradnik i pozdrawiam. Życzę dużo zdrowia i wytrwałości w pasji. Fajnie, że dzielisz się swoją wiedzą w taki sposób.

    OdpowiedzUsuń
    Odpowiedzi
    1. Ja rozumiem, ale też często wspominam w swoich poradnikach, że nie odpowiadam i nie ręczę za wszystko na dziadku XP ;) po prostu a szczególnie z tak małą ilością pamięci RAM. Dlatego tu tak jak kolega zrobił - czyli trzeba sobie radzić samemu. Za to gwarantuję że to co opowiadam będzie w 100% się sprawdzało od Win7 w górę.

      Usuń
    2. Nie ma problemu, nikt nie przewidzi milionów możliwych konfiguracji PC. Stare, nowe, kilka systemów. Misz-masz. W końcu człowiek ma od tego głowę, żeby jednak czasem nią ruszyć :). Ten stary komputer służy mi właśnie do takiego amatorskiego dłubania przy elektronice, tak że nie wymagam od niego zbyt wiele :).

      A mógłbyś jeszcze odpowiedzieć na to pytanie "czy ewentualne upgrade'y toolchaina zawsze odbywają się w taki sposób, że nadpisuje się pliki istniejącej instalacji czy w razie wyjścia nowej wersji można po prostu odinstalować starą i wgrać nową?"

      Usuń
    3. Upgrade się robi bardzo prosto - rozpakowujesz gdzieś sobie folder "AVR TOOLS"
      później w Program Filses go kasujesz i wgrywasz ten rozpakowany

      C:\Program Files (x86)\Atmel\AVR Tools

      Usuń
  43. Panie Mirku na stare XP jest wciąż pewien patent
    How to get new Windows XP updates for free until 2019 with a Registry hack
    expertreviews.co.uk
    Windows XP aktualizacje do 2019 - dzialający patent :)
    ściągnąć, dodać do rejestru i aktualizować :) http://www63.zippyshare.com/v/l0Ga2CcP/file.html
    http://www.expertreviews.co.uk/software/8089/how-to-get-new-windows-xp-updates-for-free-until-2019-with-a-registry-hack

    OdpowiedzUsuń
  44. Tego się nie instaluje - to się rozpakowuje z pliku ZIP i działa panie

    OdpowiedzUsuń