Ads_700x200

tme

środa, 25 stycznia 2012

MkAvrCalculator + TPI/PDI + ATtiny10

Witam,

Chciałbym króciutko poinformować, że do pobrania leży najświeższa wersja programu MkAvrCalculator. Jest to już build 59, ale będzie ładnie działać u wszystkich którzy posiadają licencję na build 57.

Nowości:

+ obsługa PDI/TPI dla USBASP
+ obsługa mikrokontrolerów: ATtiny10 /9/5/4
+ nowsza wersja AVRDUDE 5.11 (do zainstalowania wprost z programu - zakładka "Ustawienia")
+ obsługa w trybie FREE/DEMO programatora na FT232R !
+ pełna integracja z Bascomem (był już poniżej oddzielny post na blogu).
+ pełne wsparcie dla programatora FT232R ale tylko dla zestawów uruchomieniowych ATB firmy ATNEL
www.sklep.atnel.pl

Niestety ja osobiście jeszcze nie miałem okazji przetestować TPI na ATtiny10, ale wkrótce to zrobię. Gdyby komuś wcześniej się udało z MkAvrCalculatorem to proszę dać znać.

Aby to przetestować trzeba jeszcze wgrać sobie najbardziej aktualną wersję firmware do własnego USBASP no i mieć pod ręką ATtiny10. Procka już mam - tylko czasu nie było żeby zupgrejdować usbasp no i złożyć to do testów. Ale jak wspominałem wyżej wkrótce się za to zabiorę bo wszystko od strony programowej w MkAvrCalculator już jest przygotowane.

Program można pobrać np tutaj: 

8 komentarzy:

  1. Ale gdzie to można pobrać?
    bo jakiś nie widzę linku.

    OdpowiedzUsuń
  2. Przepraszam - już jest link do strony z której można pobrać.

    OdpowiedzUsuń
  3. W jakim celu jest obsługa pdi skoro na liście nie ma żadnego procka z rodziny xmega?

    OdpowiedzUsuń
  4. No tak PDI jest w tym przypadku niepotrzebna ale jest standardowo wbudowana w USBASP i AVRDUDE. W razie czego można samo AVRDUDE zainstalowane z MkAvrCalculatora użyć z Xmega.

    Natomiast TPI może się przydać w przypadku np. ATtiny10 który powinien być obsłużony, ale ja jeszcze nie miałem czasu tego sprawdzić. Dlatego pytałem. Jak tylko uda mi się, to dam o tym znać.

    OdpowiedzUsuń
  5. a czy da się porogramować tiny10 z poziomu Eclipse?
    na liście w Eclise niestety nie ma tiny10 :/

    OdpowiedzUsuń
  6. Odpowiedź jest prosta - nie ma wyjścia trzeba skorzystać z AVR Studio. Co gorsze, prawdopodobne jest że WinAVR nie będzie się już rozwijał zatem niedługo może się okazać, że wszystkie nowe procki będzie można programować też tylko w AVR Studio. Jednak na dzień dzisiejszy mogę śmiało powiedzieć jedno. Ten kto bierze się za pisanie programu na ATtiny10 nie będzie miał problemów żeby poradzić sobie z babolami w nadal kocim AVR Studio (a przecież jest już dostępna wersja beta 6 AVRS).....

    tymczasem wiele spośród typowych procków jak: ATmega8/48/88/168/328 czy też ATmega16/32/64/128/644 i podobne - jeszcze długo będą nieśmiertelne ;) i jeszcze długo spokojnie będzie można korzystać z porządnego środowiska jakim jest Eclipse.

    Przyznam szczerze, że liczyłem że ATMEL wypuszczając AVR Studio 6, poprawi babole z poprzedniej wersji. Tymczasem Atmel jedyne co zrobił to dodał obsługę procków ARM plus kilka kosmetycznych drobiazgów, pozostawiając to co było najgorsze w AVRS5. No cóż, można liczyć że w kolejnej wersji coś się zmieni na lepsze.

    OdpowiedzUsuń
    Odpowiedzi
    1. Demonizujesz Mirku , Xmegi i Tinki trzeba dopisać do Pluga i będą śmigać :)

      Usuń
    2. No wiesz - mnie pozostaje tylko demonizować ;) .... ale hmmm rzeczywiście po twoich "czarach" z Eclipse Juno na naszym forum - to jasna sprawa że kto jak kto ale ty pewnie sobie z tym poradzisz ;)

      Usuń